Loading...
page 14
AK and 3K Series Installation and Service Instructions
4211-143-A 02-19-10
SYMPTOMS PROBABLE CAUSES ACTION TO BE TAKEN
Control "ON". (Control light
on)
Unit won't steam.
Note:
Steam lit steadily on K30
or
Time/Temp properly
displayed on K60/KT60
Unit has not filled completely.
or
Heating elements burnt out.
or
Level probe faulty.
or
"PCA" printed circuit assembly is faulty.
1. a. Push the control "OFF".
b. Open the drain valve allowing tank to drain completely.
c. Close the drain valve.
d. Push the control "ON".
e. Unit will begin filling, listen for a click noise. Within 20 seconds after
click noise is heard, the water fill will shut off. This will indicate the
tank is full. Go to step 4, if the tank does not fill - See SYMPTOMS:
"Unit won't fill up".
2. If the tank filled but the relay click was not heard, temporarily ground the
two long probes. If the click is heard as each probe is grounded, replace the
level probe. If the click is not heard replace the "PCA" printed circuit assembly.
3. After it has been determined that the tank has filled and the click noise was
heard, remove the heating element access panel. Using a voltmeter, check the
voltage between the two wires on each heating element - the voltage should be
208V. If proper voltage is found call the factory for replacment heating
elements. If no voltage is found - check wiring diagram - call AMEREC's
Service Deparment.
Control "ON".
K60/KT60 Control displays
"E001"
Temperature sensor not connected. 1. Check that the sensor cable is connected to J4 on the "PCA" printed circuit
assembly.
2. Check the cable connection to the temperature sensor.
3. Replace sensor and/or cable - call AMEREC's Service Department.
Control "ON".
K60/KT60 Control displays
"E002"
Temperature sensor
or
cable shorted.
1. Check sensor cable for damage from nail/staple puncture.
2. Check sensor cable ends for frayed/exposed wire strands.
3. Replace sensor and/or cable - call AMEREC's Service Department.
Control "ON".
K60/KT60 Control displays
">>>º"
Steambath temperature over 132 º
or
Sensor/cable faulty.
1. If bath is too hot, shut off circuit breaker and call AMEREC's Service
Department.
2. Treat as "E002" fault above.
Control "ON"
K30 light blinking
Control improperly connected.
or
Sensor/cable faulty.
or
Control faulty.
1. Check that the control cable is properly plugged in at the control and at the
generator. K30 to primary S30 connector on the PCA. Turn off power supply,
wait one (1) minute then turn back on. Check for proper operation. If K30 is
still "blinking", turn off power supply and call AMEREC's Service Department.
2. Check sensor/cable as with K60 "E001" and "E002"
3. Replace K30 Control - call AMEREC's Service Department.
Control won't turn "OFF"
(Control light off).
Control is faulty. 1. Replace the control - call AMEREC's Service Department.
Control "OFF"
Unit won't shut off.
"PCA" printed circuit assembly is faulty. 1. Turn off the power to the generator, replace printed circuit assembly - call
AMEREC's Service Department.
Water continually sputters
out of steam head.
Foaming contaminants in the water. 1. Flush tank 3 times. See section 8, flushing procedure.
2. Call AMEREC's Service Department.
Unable to adjust Time or
Temp setting with
K60/KT60
Control faulty
or
"PCA" printed circuit assembly is faulty.
1. Replace control - call AMEREC's Service Department.
2. Replace PCA - call AMEREC's Service Department.
SECTION 10: TROUBLE SHOOTING GUIDE cont.
Loading...
Terms of Use | Privacy Policy | DMCA Policy
2006-2020 Rsmanuals.com