Loading...
4209-24 12/09/02
AK Series w/K60 Control Owners Manual page 3
SECTION 5: TROUBLE SHOOTING GUIDE
The troubleshooting guide is m eant as a general aid only. There are no user serviceable parts in the generator. All repairs should be perform ed by a qualified service
person. For additional assistance or the factory authorized service person nearest you call: AM EREC's Service Departm ent at 1-800-331-0349.
SYMPTOMS PROBABLE CAUSESACTION TO BE TAKEN
Control won't turn "ON".
(Control light off).
Improper power supplied (no power).
or
Control improperly connected.
or
Control cable is faulty.
or
Contol is faulty.
1. a. Make sure circuit breaker is "ON".
b. Using a voltmeter, check the voltage across the two fuses on the "PCA"
printed circuit assembly. Voltage should be 208V / 240V.
c. Check fuses, if the fuse(s) are blown, replace with Buss#
MDL 15/100 or equivalent fuse. If the fuse blows again - call AMEREC's
Service Department.
2. Check control(s) installed per Section 6-5 in the AK INSTALLATION AND
SERVICE INSTRUCTIONS.
3. Replace control cable - call AMEREC's Service Department.
4. Replace the control - Call AMEREC's Service Department.
Control "OFF".
Unit still makes steam.
Generator is faulty.1. Turn off the circuit breaker.
2. Call AMEREC's Service Department.
Water runs out of steam head.Generator is faulty.1. Turn off the circuit breaker.
2. Turn off the water.
3. Call AMEREC's Service Department.
Steam room too hot or cold.Temperature adjustment needs setting.1. See Section 3, "Temperature Adjustment".
2. Call AMEREC's Service Department.
Control "ON".
K60 Control displays "E001".
Temperature sensor not connected.1. Check that the sensor cable is connected to J4 on the PCA printed circuit
assembly.
2. Check the cable connection to the temperature sensor.
3. Replace sensor and/or cable - call AMEREC's Service Department.
Control "ON".
K60 Control displays "E002".
Temperature sensor.
or
cable shorted.
1. Check sensor cable for damage from nail/staple puncture.
2. Check sensor cable ends for frayed/exposed wire strands.
3. Replace sensor and/or cable - call AMEREC's Service Department.
Control "ON".
K60 Control displays ">>>º".
Steambath temperature over 132 º.
or
Sensor/cable is faulty.
1. If bath is too hot, shut off circuit breaker and call AMEREC's Service Department.
2. Treat as "E002" fault above.
Control won't turn "OFF".
(Control light on).
Control is faulty.1. Replace the control - call AMEREC's Service Department.
Control "ON". (Control light on)
Unit won't steam.
Note: Time/Temp properly.
displayed on K60.
Unit has not filled completely.
or
Generator is faulty.
1. Wait at least 10 minutes after turning on the control.
2. Call AMEREC's Service Department.
Unable to adjust Time or Temp
setting with K60.
Control is faulty.
or
Generator is faulty.
1. Replace control - call AMEREC's Service Department.
2. Replace PCA - call AMEREC's Service Department.
Sudden increases in rate water
sputters out of steam head.
Foaming contaminants in the water
supply.
1. Flush tank 3 times. See Section 4.
Loading...
Terms of Use | Privacy Policy | DMCA Policy
2006-2020 Rsmanuals.com